Appendix: nwamd(1M) Man Page
NAME: nwamd - network auto-magic daemon
DESCRIPTION: nwamd is a system daemon to manage network interfaces. This
daemon is started automatically and should not be invoked directly. It does not
constitute a programming interface.
OPERATION: Whether this daemon is enabled or not depends on your installation medium.
To check, enter the following at the command line:
% svcs svc:/network/physical
The two instances will be listed: one as disabled, the other
as online. If the nwam instance is online then this daemon will be running.
The two instances correspond to the two modes of network configuration: the default
instance is for manual mode, while the nwam instance is for auto-magic mode.
To go from manual mode to auto-magic mode:
% svcadm disable svc:/network/physical:default
% svcadm enable svc:/network/physical:nwam
To go from auto-magic mode to manual mode:
% svcadm disable svc:/network/physical:nwam
% svcadm enable svc:/network/physical:default
CAUTION: When switching modes like this, all network interfaces will be brought down
then back up, thus if a different IP address is configured in this
process, existing applications and sessions may be disrupted.
Note - In auto-magic mode, there is a limitation that only one link is
active at a time. This mode is thus not recommended for machines
which use more than one link at once. For machines with wired and
wireless links, wired is preferred by default, although this can be adjusted by
altering the order of the lines in the plain text file /etc/nwam/llp. Note,
however, that this interface is Volatile and may change in a future release.
PROFILES: Note that all interfaces listed in this section are Volatile and may
change in a future release. They are documented here so that those wishing
to experiment with this may do so. Profiles are a mechanism for
making multiple related changes to the system configuration after IP service is available.
There is not direct support for them yet, but a “roll
your own” mechanism is provided for now. Once an interface is brought up
and an IP address is configured for it, the daemon looks for /etc/nwam/ulp/check-conditions; if
it exists and is executable, it is run. This is expected to
print a single line of output, which is the name of the profile
which the user wishes to be activated based on the current conditions. If
such a line is read successfully (foo in this example), then /etc/nwam/ulp/foo/bringup is
executed. Likewise, when the interface gets torn down for whatever reason, /etc/nwam/ulp/foo/teardown
is executed. The bringup and teardown scripts are invoked via pfexec(1) with
default basic privileges. Samples for each of these scripts can be found at:
WIRELESS: When no wired link is available, a scan for wireless LANs will
be done, and the resulting list offered via a GUI pop-up to prompt
the console user to select his/her preference. If a successful connection is made,
the WLAN in question will be stored in the plain text file /etc/nwam/known_wifi_nets
and subsequently the daemon may connect to any WLAN in that list without
prompting again. Should a user wish to revoke his/her preference for a WLAN
in that list, editing the file and deleting the line with the entry
should suffice. Note, however, that this interface is Volatile and may change in
a future release.
ATTRIBUTE: See attributes(5) for descriptions of the following attributes:
SEE ALSO: svcs(1), svcadm(1M), attributes(5), smf(5)
NOTES: The networking service is managed by the service management facility, smf(5), under
the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can
be performed using svcadm(1M). The service's status can be queried using the svcs(1)