Follow Techotopia on Twitter

On-line Guides
All Guides
eBook Store
iOS / Android
Linux for Beginners
Office Productivity
Linux Installation
Linux Security
Linux Utilities
Linux Virtualization
Linux Kernel
System/Network Admin
Programming
Scripting Languages
Development Tools
Web Development
GUI Toolkits/Desktop
Databases
Mail Systems
openSolaris
Eclipse Documentation
Techotopia.com
Virtuatopia.com

How To Guides
Virtualization
General System Admin
Linux Security
Linux Filesystems
Web Servers
Graphics & Desktop
PC Hardware
Windows
Problem Solutions
Privacy Policy

  




 

 

Eclipse Platform Plug-in Development Environment Guide
Previous Page Home Next Page

Plug-in Export

Open the plugin export wizard File > Export... > Plug-in Development > Deployable plug-ins and fragments .

Plug-in Selection

The wizard displays all the non-binary plug-ins found in the workspace.

Plug-ins

Select the plug-ins that you want to export. If you find yourself exporting the same set of plug-ins over and over, you can press Working Set... to define a plug-in working set.

Destination

You can choose to export the plug-ins to a directory or to a ZIP archive. You can also choose to export the plug-ins in a runnable format and have them installed into your currently running Eclipse host.

Destination

If you choose to export to a Directory (the default), the plug-ins will be placed in a plugins/ subdirectory of the chosen directory.

If you choose to export to an Archive File, all the plug-ins will be packaged in a single ZIP archive. The directory structure inside the ZIP also starts with plugins/ at its root.

If you choose to export and Install the plug-ins will be exported in a runnable format and a p2 repository will be generated. After the export completes, an installation operation will run to install the plug-ins. You will be prompted to restart Eclipse when the installation completes. To uninstall your plug-ins you must use the Installation Details button on the About Dialog (available by going to Help > About Eclipse SDK). For more details see Exporting and Installing into the Host

Options

Options

The Export source option results in the exporting of source code as well as binaries. There are two ways to package source with your exported plug-in. The Generated Source Bundles option will add the ant commands to the export to create separate source bundles for each of the exported plug-ins. For more information on source bundles see the PDE Build entry on Individual Source Bundles. The second option is to Include source in exported plug-ins. This option will package the source files in a src/ folder at the root of the JAR (if exporting in a JAR format). If the plug-in is packaged as a flat directory, the source code will be placed in a source ZIP inside the plug-in directory as a sibling to the library JAR.

The Package plug-ins as individual JAR archives option packages each plug-in as a JAR. This option is recommended for plug-ins whose code is stored at the root (i.e. plug-ins that have no MANIFEST.MF Bundle-ClassPath header or the header is of the form Bundle-ClassPath: .). Nested JARs are strongly discouraged as they hinder performance; since, the runtime will have to extract these JARs at runtime. Therefore, if the plug-in's code is packaged in a JAR, it is recommended to keep the deployed plug-in as a flat directory.

The Qualifier replacement option enables you to substitute a value for the qualifier element in a plug-in's version. The plug-ins version must be in the following format: <major>.<minor>.<micro>.qualifier. For example: 3.3.0.qualifier. Normally, the qualifier represents a build date or identifier.

The Save as Ant script option lets you save the settings of the export operation so that it can be re-executed at a later time without having to go through the wizard again. Like the export operation, the Ant task runs as an asynchronous job; therefore, it may not be suitable to incorporate it as a part of a larger Ant script.

The Save as Ant script option lets you save the settings of the export operation so that it can be re-executed at a later time without having to go through the wizard again. Like the export operation, the Ant task runs as an asynchronous job; therefore, it may not be suitable to incorporate it as a part of a larger Ant script.

Allow binary cycles in target platform is an option that controls how the export operation deals with cycles in the dependency graph for a plug-in. PDE Build cannot compile if a cycle is detected. However, if a cycle only contains binary plug-ins from the target platform, turning on this option will allow PDE Build to continue.

If the Use class files compiled in the workspace option is turned on, rather than compiling files as part of the export operation, the binary files in the workspace that were compiled by Eclipse are used. This should improve performance as it skips the compilation phase, but your workspace must have successfully compiled

JAR Signing

The JAR Signing tab is only available when the Package as individual JAR archives option is selected on the Options tab.

JAR Signing

To sign the JARs, you must be running Eclipse with a full JDK, rather than just a JRE.

The Keystore location, Keypass, Alias and Password fields are all required for the signing operation.


Related reference

Export Wizards
Feature Export Wizard

Related tasks

Export and Install into the Running Host


 
 
  Published under the terms of the Eclipse Public License Version 1.0 ("EPL") Design by Interspire